Password Recovery Procedure for the Cisco 1700, 2600, 3600, etc

Ξ June 4th, 2007 | → 18 Comments | ∇ Cisco, Technology |

This document describes the procedure for recovering enable password or enable secret passwords. These passwords are used to protect access to privileged EXEC and configuration modes. The enable password password can be recovered, but the enable secret password is encrypted and can only be replaced with a new password using the procedure below.

This password recovery procedure can also be used for the following products:

* Cisco 806
* Cisco 827
* Cisco uBR900
* Cisco 1003
* Cisco 1004
* Cisco 1005
* Cisco 1400
* Cisco 1600
* Cisco 1700
* Cisco 2600
* Cisco 3600
* Cisco 4500
* Cisco 4700
* Cisco AS5x00
* Cisco 6×00
* Cisco 7000 (RSP7000)
* Cisco 7100
* Cisco 7200
* Cisco 7500
* Cisco uBR7100
* Cisco uBR7200
* Cisco uBR10000
* Cisco 12000
* Cisco LS1010
* Catalyst 2948G-L3
* Catalyst 4840G
* Catalyst 4908G-L3
* Catalyst 5500 (RSM)
* Catalyst 8510-CSR
* Catalyst 8510-MSR
* Catalyst 8540-CSR
* Catalyst 8540-MSR
* Cisco MC3810
* Cisco NI-2
* Cisco VG200 Analog Gateway
* Route Processor Module

Step-by-Step Procedure

Follow this procedure to recover the enable password or enable secret passwords.

1. Attach a terminal or PC with terminal emulation to the console port of the router. Use the following terminal settings:

9600 baud rate
No parity
8 data bits
1 stop bit
No flow control

2. If you still have access to the router, type show version and record the setting of the configuration register; it is usually 0x2102 or 0x102. Click here to see the output of a show version command.

3. If you don’t have access to the router (because of a lost login or tacacs password), you can safely consider that your configuration register is set to 0x2102.

4. Using the power switch, turn off the router and then turn it back on.
Important: To simulate step 4 on a Cisco 6400, pull out and then replace the Node Route Processor (NRP) or Node Switch Processor (NSP) card.
To simulate step 4 on a Cisco 6×00 using NI-2, pull out and then replace the NI-2 card.

5. Press Break on the terminal keyboard within 60 seconds of the power-up to put the router into ROMMON.
If the break sequence doesn’t work, see Standard Break Key Sequence Combinations During Password Recovery for other key combinations.

6. Type confreg 0x2142 at the rommon 1> prompt to boot from Flash without loading the startup configuration from the nonvolatile RAM (NVRAM).

7. Type reset at the rommon 2> prompt.
The router reboots but ignores its saved configuration.

8. Type no after each setup question or press Ctrl-C to skip the initial setup procedure.

9. Type enable at the Router> prompt.
This puts you in enable mode where you can see the Router# prompt.

10. Important: Type configure memory or copy startup-config running-config to copy the NVRAM into memory. Do not type configure terminal or copy running-config startup-config or write memory. This erases the router configuration stored in the NVRAM.

11. Type write terminal or show running-config.
The show running-config and write terminal commands show the configuration of the router. In this configuration, you see under all the interfaces the shutdown command, which means all interfaces are currently shutdown. Also, you can see the passwords (enable password, enable secret, vty, console passwords, and so on) either in encrypted or unencrypted format. The unencrypted passwords can be re-used; the encrypted ones have to be replaced with new passwords.

12. Type configure terminal and make the changes.
The prompt is now hostname(config)#.

13. Type enable secret < password > to change the enable secret password, for example.

14. Issue the no shutdown command on every interface that is used. If you issue a show ip interface brief command, once you exit the configuration mode (Ctrl-z), every interface that you want to use should be “up up”.

15. Type config-register 0x2102, or the value you recorded in step 2. This makes the router load the startup configuration from the NVRAM during the next reload.

16. Press Ctrl-z or End to leave the configuration mode.
The prompt is now hostname#.

17. Type write memory or copy running-config startup-config to commit the changes.

Sample Output
The sample output shown here is the result of the password recovery procedure on a Cisco 4700 Series Router. Even if you are not using a 4700 router, this example should be almost exactly what you experience on your device.

Router>enable

Password:

Password:

Password:

% Bad secrets

Router>show version
Cisco Internetwork Operating System Software
IOS ™ 4500 Software (C4500-IS-M), Version 12.2(10b), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 11-Jul-02 17:29 by pwade
Image text-base: 0x60008948, data-base: 0x60C74000

ROM: System Bootstrap, Version 5.2(7b) [mkamson 7b], RELEASE SOFTWARE (fc1)

BOOTLDR: 4500 Software (C4500-BOOT-M), Version 11.3(10),
RELEASE SOFTWARE (fc1)

Router uptime is 0 minutes

System returned to ROMby reload at 17:34:58 UTC Tue Aug 1 1995

System image file is “flash:c4500-is-mz.122-10b.bin”

cisco 4700 (R4K) processor (revision B) with 32768K/16384K bytes of memory.

Processor board ID 02169303

R4600 CPU at 133Mhz, Implementation 32, Rev 2.0, 512KB L2 Cache

G.703/E1 software, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

6 Ethernet/IEEE 802.3 interface(s)

8 Serial network interface(s)

128K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

4096K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2102

Router>

!— The router was just powercycled and during bootup a
!—break sequence was sent to the router.

!

monitor: command “cisco2-C4500” aborted due to user interrupt

>

>confreg 0x2142

You must reset or power cycle for new config to take effect

>reset

System Bootstrap, Version 5.2(7b) [mkamson 7b], RELEASE SOFTWARE (fc1)

Copyright (c) 1995 by cisco Systems, Inc.

C4500 processor with 32768 Kbytes of main memory

Self decompressing the image : ##################################

#######################################################

################################# [OK]

program load complete, entrypt: 0x80008000, size: 0x6a6b30

Self decompressing the image : ################################

#################################### [OK]

Restricted Rights Legend

…….

< ...snip>

……

— System Configuration Dialog —

Would you like to enter the initial configuration dialog?[yes/no]:n

Press RETURN to get started!

00:00:05: %LINK-3-UPDOWN: Interface Serial0, changed state to down
…… < ..snip>

00:01:29: %LINK-5-CHANGED: Interface Ethernet5, changed state to
administratively down

Router>

Router>enable
Router#copy startup-config running-config
Destination filename [running-config]?

1012 bytes copied in 0.276 secs (3667 bytes/sec)

Router#show running-config
Building configuration…
Current configuration : 1084 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$uQ7K$rfZtMRsWsFagqsW4/9K0b1

!— Since the password is encrypted, we need to replace
!— the password with the new one.

!
ip subnet-zero
!
!
!
!
interface Ethernet0
ip address 10.10.10.1 255.0.0.0
media-type 10BaseT
!
interface Ethernet1
no ip address
shutdown
media-type 10BaseT
!
Ouput Omitted
!
interface Serial0
ip address 172.16.1.1 255.255.0.0
!
Ouput Omitted
!
ip classless
no ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#enable secret < password > [Choose a strong password with at least one capital letter, one number, and one special character.]

Router(config)#^Z

00:05:23: %SYS-5-CONFIG_I: Configured from console by console

Router#show ip interface brief

…< ...output omitted>

Router#

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface ethernet 0

Router(config-if)#no shutdown

Router(config-if)#

00:08:06: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up

Router(config-if)#^Z

Router#

00:09:21: %SYS-5-CONFIG_I: Configured from console by console

Router#

Router#

Router#copy running-config startup-config

Destination filename [startup-config]?

Building configuration…

[OK]

Router#show version
Cisco Internetwork Operating System Software
IOS ™ 4500 Software (C4500-IS-M), Version 12.2(10b), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 11-Jul-02 17:29 by pwade
Image text-base: 0x60008948, data-base: 0x60C74000

ROM: System Bootstrap, Version 5.2(7b) [mkamson 7b], RELEASE SOFTWARE (fc1)

BOOTLDR: 4500 Software (C4500-BOOT-M), Version 11.3(10), RELEASE SOFTWARE(fc1)
Router uptime is 10 minutes

……< ..snip>

……

8192K bytes of processor board System flash (Read/Write)

4096K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2142

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#config-register 0x2102
Router(config)#^Z
Router#show version
Cisco Internetwork Operating System Software
IOS ™ 4500 Software (C4500-IS-M), Version 12.2(10b), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 11-Jul-02 17:29 by pwade
Image text-base: 0x60008948, data-base: 0x60C74000

ROM: System Bootstrap, Version 5.2(7b) [mkamson 7b], RELEASE SOFTWARE (fc1)

BOOTLDR: 4500 Software (C4500-BOOT-M), Version 11.3(10), RELEASE SOFTWARE (fc1)

Router uptime is 11 minutes

…….< ..snip>

……

00:11:02: %SYS-5-CONFIG_I: Configured from console 4096K bytes of processor board
Boot flash (Read/Write)

Configuration register is 0x2142 (will be 0x2102 at next reload)

Source: cisco.com

 

18 Responses to ' Password Recovery Procedure for the Cisco 1700, 2600, 3600, etc '

Subscribe to comments with RSS or TrackBack to ' Password Recovery Procedure for the Cisco 1700, 2600, 3600, etc '.

  1. syafik said,

    on July 25th, 2007 at 8:51 am

    apa yang membedakan router 2600,dan tipe-tipenya?
    misalkan 2620,2621,dst..
    terima kasih

  2. Mudji said,

    on July 26th, 2007 at 12:38 am

    Yang berbeda adalah, fisik dan fitur-fiturnya.
    Untuk lebih jelasnya bisa akses ke http://www.cisco.com

  3. verdy said,

    on August 1st, 2007 at 10:16 pm

    Pagi bang,
    Tulung pencerahannya dan solusi untuk trouble shoot switch Catalyst 4840, tidak dapat di gunalan.

    saat di console : tidak punya display atau sesaat yang muncul yaitu : ::::::

    apakah no Nvram, gimana cara copy ios sys , sementara display switch> tidak display

    Tolong, pencerahannya bang dan solusinya

    salam,
    verdy
    verdysgn@yahoo.com

  4. Mudji said,

    on August 15th, 2007 at 2:15 pm

    Coba anda masuk ke ROMMON>

    caranya adalah:
    1. matikan power.
    2. Nyalakan power
    3. Sekitar 10 detik, kemudian tekan CTRL+Break berulang-ulang, sampai muncul ROMMON> pada display PC.
    4. Anda bisa coba cek setting Console di routernya, bisa jadi tidak match dengan hyperterminal, seharusnya Bit per second: 9600, Data bits : 8, Parity : None, Stop bits: 1, Flow Control : None.
    Jika sudah persis sama, silakan di reload lagi utk di test.
    5. Jika belum berhasil, Anda bisa upload IOS melalui ROMMON.

    Thanks

  5. ferdian said,

    on October 29th, 2007 at 1:23 pm

    mo ikutan gabung nih mas mudji
    saya kan punya router 2600series tapi kok pas saya konek in pake roll over db 9 ke rj 45 kok ga mo konek yan apa ada yang salah ….
    makasih

  6. Mudji said,

    on October 30th, 2007 at 12:08 am

    Ferdian,
    Coba cek setting di hyperTerminalnya, terutama utk speed-nya.
    Apa mungkin speed console di router 2600 sudah pernah diubah, atau mungkin kabel consolenya bermasalah, port console di router atau port db di pc nya yang problem.

    salam
    Mudji

  7. aco said,

    on November 30th, 2007 at 6:37 pm

    mas, tolong ajarin configure untuk yg 1811 ya. minta contoh settingnya sampe bisa digunakan, thanks

  8. Dwi Nurcahya said,

    on February 2nd, 2008 at 7:36 pm

    saya butuh password recovery untuk excel 2003,bisa bantu? karena say punya file yang kebetulan beberapa passwordnya lua karena berneda neda dulu passwordnya, mohon balas…..

  9. aji said,

    on May 5th, 2008 at 6:32 am

    mas mudji, tolong ajarin configure untuk cisco 827 4v, 871, 1811, 1841
    tolong dikirim lewat email aja y mas….
    buat bahan laporan kerja praktek saya
    makasih

  10. mudji said,

    on May 6th, 2008 at 11:25 am

    Hello Aji,
    Konfigurasi router cisco spt type yang anda sebutkan adalah sama dengan yang saya publish di situs ini.
    Untuk yang voice anda bisa baca di http://mudji.net/press/?p=244

    thanks

  11. fendy said,

    on September 5th, 2008 at 7:19 am

    Hello mas mudji, saya punya cisco 1700 akan saya gunakan utk sharing internet n email, gimana cara settingnya, tolong klo bisa dikirim ke-email aja thanks

  12. mudji said,

    on September 15th, 2008 at 10:33 pm

    Hi Fendy,
    Cara konfigurasi untuk sharing internet termasuk email dengan menggunakan cisco router bisa anda baca di http://mudji.net/NAT.zip

  13. bang opang said,

    on May 27th, 2010 at 9:02 pm

    Mas minta tolong donk ?
    aku punya ip 202.171.25.210 255.-.-.224
    aku mau masukin ip itu ke router 3600 , gimana caranya :

    trus akku trunking ke switch

    kasi tau caranya donk : dan commennya . tolong

    heheheheheh
    assalamualaikum

  14. dainkul said,

    on August 6th, 2010 at 8:23 pm

    om mudji tolong donk cara reset password cisco 2621

  15. mudji said,

    on August 7th, 2010 at 6:22 pm

    @Bang Opang,
    cara setting nya bisa dilihat di http://mudji.net/press/?p=227#more-227
    – untuk trunk-nya sebaiknya gunakan encapsulation .1Q

  16. mudji said,

    on August 7th, 2010 at 6:23 pm

    @dainkul, cara resetnya sama prosedurnya dengan artikel ini.

  17. Issac Maez said,

    on October 26th, 2010 at 10:21 pm

    Interesting Article. Hoping that you will continue posting an article having a useful information. Thanks a lot!

  18. suratin said,

    on January 7th, 2011 at 6:12 am

    trimakasih atas postingan mudah-mudahan bisa membantu dan sangat membantu sekali buat kami yang masih pemula ini, trimakasih banget……

Leave a reply